#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Start Time : (.+)"
Local $sString = "Text at the beginning" & @CRLF & _
"Alert : Alert DESC" & @CRLF & _
"Some other text blah blah" & @CRLF & _
"Start Time : 04/17/2023 09:00:00 AM" & @CRLF & _
"End Time : 04/17/2023 12:00:00 PM" & @CRLF & _
"Other text etc etc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")