import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Start Time : (.+)";
final String string = "Text at the beginning\n"
+ "Alert : Alert DESC\n"
+ "Some other text blah blah\n"
+ "Start Time : 04/17/2023 09:00:00 AM\n"
+ "End Time : 04/17/2023 12:00:00 PM\n"
+ "Other text etc etc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}