package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Start Time : (.+)`)
var str = `Text at the beginning
Alert : Alert DESC
Some other text blah blah
Start Time : 04/17/2023 09:00:00 AM
End Time : 04/17/2023 12:00:00 PM
Other text etc etc`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}