using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(\s+|^)(ADD|CHANGE|MODIFY)\b(\s+COLUMN)?((\s|.)*(BEFORE|AFTER))";
string input = @"add
column asd asd asd
asdasd after ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}