re = /(?i)(\s+|^)(ADD|CHANGE|MODIFY)\b(\s+COLUMN)?((\s|.)*(BEFORE|AFTER))/m
str = 'add
column asd asd asd
asdasd after '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end