// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(\s+|^)(ADD|CHANGE|MODIFY)\b(\s+COLUMN)?((\s|.)*(BEFORE|AFTER))").unwrap();
let string = "add
column asd asd asd
asdasd after ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}