#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\d\-\/]+"
Local $sString = "5-8-24 emailed AM…pt was inmate per call note in ehr lm" & @CRLF & _
"_Letter aer to patient bucket…RK”" & @CRLF & _
"04/03/2024_Task escalated to review…JS" & @CRLF & _
"03/01/2024_Secondary denied as office visit are not covered as per patient plan, hence escalated team for further assistance…SM" & @CRLF & _
"03212024_Per web, claim got received and processed and denied deductible not covered. therefore, escalating to team…KC" & @CRLF & _
"01/03/2023_Claim denied for invalid code so claim escalated to team for further assistance Cl…SS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")