import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d\\-\\/]+";
final String string = "5-8-24 emailed AM…pt was inmate per call note in ehr lm\n"
+ "_Letter aer to patient bucket…RK”\n"
+ "04/03/2024_Task escalated to review…JS\n"
+ "03/01/2024_Secondary denied as office visit are not covered as per patient plan, hence escalated team for further assistance…SM\n"
+ "03212024_Per web, claim got received and processed and denied deductible not covered. therefore, escalating to team…KC\n"
+ "01/03/2023_Claim denied for invalid code so claim escalated to team for further assistance Cl…SS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}