# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\d\-\/]+"
test_str = ("5-8-24 emailed AM…pt was inmate per call note in ehr lm\n"
"_Letter aer to patient bucket…RK”\n"
"04/03/2024_Task escalated to review…JS\n"
"03/01/2024_Secondary denied as office visit are not covered as per patient plan, hence escalated team for further assistance…SM\n"
"03212024_Per web, claim got received and processed and denied deductible not covered. therefore, escalating to team…KC\n"
"01/03/2023_Claim denied for invalid code so claim escalated to team for further assistance Cl…SS")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.