package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,2}|\d{1,2}\.\d{1,2}|100\.[0]{1,2}|100)$`)
var str = `0
0.00
0.769
767.99
88.75
100.00
5
65
00
000
00.00
12
100.22
100.
100
sad
0w
0.
.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}