const regex = /^(\d{1,2}|\d{1,2}\.\d{1,2}|100\.[0]{1,2}|100)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,2}|\\d{1,2}\\.\\d{1,2}|100\\.[0]{1,2}|100)$', 'gm')
const str = `0
0.00
0.769
767.99
88.75
100.00
5
65
00
000
00.00
12
100.22
100.
100
sad
0w
0.
.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}