# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{1,2}|\d{1,2}\.\d{1,2}|100\.[0]{1,2}|100)$"
test_str = ("0\n"
"0.00\n"
"0.769\n"
"767.99\n"
"88.75\n"
"100.00\n"
"5\n"
"65\n"
"00\n"
"000\n"
"00.00\n"
"12\n"
"100.22\n"
"100.\n"
"100\n"
"sad\n"
"0w\n"
"0.\n"
".0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.