#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\S+ ?\S+$)\d(?: ?\d){3}[a-zA-Z ]{2,3}$"
Local $sString = "1111 ZZ" & @CRLF & _
"111 1ZZ" & @CRLF & _
"11 11ZZ" & @CRLF & _
"1 111ZZ" & @CRLF & _
"1111ZZ" & @CRLF & _
"1111 ZZ" & @CRLF & _
"" & @CRLF & _
"9999 1A" & @CRLF & _
"11111 Z" & @CRLF & _
"1111111" & @CRLF & _
"11 11 ZZ" & @CRLF & _
"1111 AAA" & @CRLF & _
"11 1A " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")