using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\S+ ?\S+$)\d(?: ?\d){3}[a-zA-Z ]{2,3}$";
string input = @"1111 ZZ
111 1ZZ
11 11ZZ
1 111ZZ
1111ZZ
1111 ZZ
9999 1A
11111 Z
1111111
11 11 ZZ
1111 AAA
11 1A
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}