$re = '/^(?=\S+ ?\S+$)\d(?: ?\d){3}[a-zA-Z ]{2,3}$/m';
$str = '1111 ZZ
111 1ZZ
11 11ZZ
1 111ZZ
1111ZZ
1111 ZZ
9999 1A
11111 Z
1111111
11 11 ZZ
1111 AAA
11 1A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);