const regex = /^(?=\S+ ?\S+$)\d(?: ?\d){3}[a-zA-Z ]{2,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\S+ ?\\S+$)\\d(?: ?\\d){3}[a-zA-Z ]{2,3}$', 'gm')
const str = `1111 ZZ
111 1ZZ
11 11ZZ
1 111ZZ
1111ZZ
1111 ZZ
9999 1A
11111 Z
1111111
11 11 ZZ
1111 AAA
11 1A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}