package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.* Test .* recorded an issue at ([a-zA-Z0-9_\/ ]+\.swift):([0-9]+):([0-9]+):`)
var str = ` Test assignTimes_withExplicitAtEnd_assignsBeforeExplicit() recorded an issue at CanvasTimeAssignmentTests.swift:97:3: Expectation failed:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}