import Foundation
let pattern = #"^.* Test .* recorded an issue at ([a-zA-Z0-9_\/ ]+\.swift):([0-9]+):([0-9]+):"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" Test assignTimes_withExplicitAtEnd_assignsBeforeExplicit() recorded an issue at CanvasTimeAssignmentTests.swift:97:3: Expectation failed:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)