re = /^.* Test .* recorded an issue at ([a-zA-Z0-9_\/ ]+\.swift):([0-9]+):([0-9]+):/m
str = ' Test assignTimes_withExplicitAtEnd_assignsBeforeExplicit() recorded an issue at CanvasTimeAssignmentTests.swift:97:3: Expectation failed:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end