package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-zA-Z]+ )?((?:\d{11}|\d{14})|(?:\d{3}\.\d{3}\.\d{3}\-\d{2}|\d{3}\d{3}\d{3}\-\d{2})|(?:\d{2}\.\d{3}.\d{3}\/\d{4}-\d{2}|\d{2}\d{3}\d{3}\d{4}-\d{2})\b)`)
var str = `Testing 42702434884
Testing 064352729-13
05.994.401/0001-53
Testing 134.632.125-03`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}