const regex = /^(?:[a-zA-Z]+ )?((?:\d{11}|\d{14})|(?:\d{3}\.\d{3}\.\d{3}\-\d{2}|\d{3}\d{3}\d{3}\-\d{2})|(?:\d{2}\.\d{3}.\d{3}\/\d{4}-\d{2}|\d{2}\d{3}\d{3}\d{4}-\d{2})\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-zA-Z]+ )?((?:\\d{11}|\\d{14})|(?:\\d{3}\\.\\d{3}\\.\\d{3}\\-\\d{2}|\\d{3}\\d{3}\\d{3}\\-\\d{2})|(?:\\d{2}\\.\\d{3}.\\d{3}\\\/\\d{4}-\\d{2}|\\d{2}\\d{3}\\d{3}\\d{4}-\\d{2})\\b)', 'gm')
const str = `Testing 42702434884
Testing 064352729-13
05.994.401/0001-53
Testing 134.632.125-03`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}