import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z]+ )?((?:\\d{11}|\\d{14})|(?:\\d{3}\\.\\d{3}\\.\\d{3}\\-\\d{2}|\\d{3}\\d{3}\\d{3}\\-\\d{2})|(?:\\d{2}\\.\\d{3}.\\d{3}\\/\\d{4}-\\d{2}|\\d{2}\\d{3}\\d{3}\\d{4}-\\d{2})\\b)";
final String string = "Testing 42702434884 \n"
+ "Testing 064352729-13\n"
+ "05.994.401/0001-53\n"
+ "Testing 134.632.125-03";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}