re = /^(?:[a-zA-Z]+ )?((?:\d{11}|\d{14})|(?:\d{3}\.\d{3}\.\d{3}\-\d{2}|\d{3}\d{3}\d{3}\-\d{2})|(?:\d{2}\.\d{3}.\d{3}\/\d{4}-\d{2}|\d{2}\d{3}\d{3}\d{4}-\d{2})\b)/m
str = 'Testing 42702434884
Testing 064352729-13
05.994.401/0001-53
Testing 134.632.125-03'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end