using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"o";
string substitution = @"\0";
string input = @"foobar";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}