import Foundation
let pattern = #"o"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foobar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)