package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)o`)
var str = `foobar`
var substitution = "\0"
fmt.Println(re.ReplaceAllString(str, substitution))
}