use strict;
my $str = 'foobar';
my $regex = qr/o/mp;
my $subst = '\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";