using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<title>.*))(MAIL:|HOST:)";
string input = @"TITLE MSG HOST:HOSTNAME MAIL:a@b.com
TITLE - sqlChecks for PayOffChecks [21/02/2019-22:00]: MAIL:a@b.com HOST:HOSTNAME
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}