$re = '/(?:(?<title>.*))(MAIL:|HOST:)/m';
$str = 'TITLE MSG HOST:HOSTNAME MAIL:a@b.com
TITLE - sqlChecks for PayOffChecks [21/02/2019-22:00]: MAIL:a@b.com HOST:HOSTNAME
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);