const regex = /(?:(?<title>.*))(MAIL:|HOST:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<title>.*))(MAIL:|HOST:)', 'gm')
const str = `TITLE MSG HOST:HOSTNAME MAIL:a@b.com
TITLE - sqlChecks for PayOffChecks [21/02/2019-22:00]: MAIL:a@b.com HOST:HOSTNAME
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}