package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?<title>.*))(MAIL:|HOST:)`)
var str = `TITLE MSG HOST:HOSTNAME MAIL:a@b.com
TITLE - sqlChecks for PayOffChecks [21/02/2019-22:00]: MAIL:a@b.com HOST:HOSTNAME
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}