#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bch.*?\K\b(?:\d+|VI{0,3}|I(?:[XV]|I{0,2}))\b"
Local $sString = ""chapter some word 12"" & @CRLF & _
""chapter some word 12 some word"" & @CRLF & _
""chapter some word I some word"" & @CRLF & _
""chapter some word II some word"" & @CRLF & _
""chapter some word III some word"" & @CRLF & _
""chapter some word iv some word"" & @CRLF & _
""chapter some word v some word"" & @CRLF & _
""chapter some word vi some word"" & @CRLF & _
""chapter some word vii some word"" & @CRLF & _
""chapter some word viI some word"" & @CRLF & _
""chapter some word ix some word"" & @CRLF & _
""chapter some word x some word"" & @CRLF & _
""chapter some word xi some word"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")