import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bch.*?\\K\\b(?:\\d+|VI{0,3}|I(?:[XV]|I{0,2}))\\b";
final String string = "\"chapter some word 12\"\n"
+ "\"chapter some word 12 some word\"\n"
+ "\"chapter some word I some word\"\n"
+ "\"chapter some word II some word\"\n"
+ "\"chapter some word III some word\"\n"
+ "\"chapter some word iv some word\"\n"
+ "\"chapter some word v some word\"\n"
+ "\"chapter some word vi some word\"\n"
+ "\"chapter some word vii some word\"\n"
+ "\"chapter some word viI some word\"\n"
+ "\"chapter some word ix some word\"\n"
+ "\"chapter some word x some word\"\n"
+ "\"chapter some word xi some word\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}