$re = '/\bch.*?\K\b(?:\d+|VI{0,3}|I(?:[XV]|I{0,2}))\b/mi';
$str = '"chapter some word 12"
"chapter some word 12 some word"
"chapter some word I some word"
"chapter some word II some word"
"chapter some word III some word"
"chapter some word iv some word"
"chapter some word v some word"
"chapter some word vi some word"
"chapter some word vii some word"
"chapter some word viI some word"
"chapter some word ix some word"
"chapter some word x some word"
"chapter some word xi some word"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);