use strict;
my $str = '"chapter some word 12"
"chapter some word 12 some word"
"chapter some word I some word"
"chapter some word II some word"
"chapter some word III some word"
"chapter some word iv some word"
"chapter some word v some word"
"chapter some word vi some word"
"chapter some word vii some word"
"chapter some word viI some word"
"chapter some word ix some word"
"chapter some word x some word"
"chapter some word xi some word"
';
my $regex = qr/\bch.*?\K\b(?:\d+|VI{0,3}|I(?:[XV]|I{0,2}))\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}