# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\S+ )([^\n]*\n)\1([^\n]*\n)/$1$2/gsm;t' <<< "ABC-123 BLA bla</br>
ABC-123 lala lala</br>
ABC-234 AAA</br>
ABC-234 BBB</br></br>
"