#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)(^\S+ )([^\n]*\n)\1([^\n]*\n)"
Local $sString = "ABC-123 BLA bla</br>" & @CRLF & _
"ABC-123 lala lala</br>" & @CRLF & _
"ABC-234 AAA</br>" & @CRLF & _
"ABC-234 BBB</br></br>" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)