use strict;
my $str = 'ABC-123 BLA bla</br>
ABC-123 lala lala</br>
ABC-234 AAA</br>
ABC-234 BBB</br></br>
';
my $regex = qr/(^\S+ )([^\n]*\n)\1([^\n]*\n)/smp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";