using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=\n\n)|\A\n*|\n{2,})
[ ]{0,3}
(?<tag_all>
(?:
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
>
(?<html_content>.*?)
(?<tag_close>
<
[[:blank:]\h\v]*
\/
\g{tag_name}
[[:blank:]\h\v]*
>
)
)
|
(?:
<!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->
)
|
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
(?<html_after>
\z
|
[ ]*\n{1,2}
(?!
[[:blank:]\h\v]*
(?:
(?:
<
[[:blank:]\h\v]*
[a-zA-Z0-9][\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
>
)
|
(?:
<
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
[\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
)
)
)
(?(DEFINE)
(?<tag_attr>
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[^\""\'[:blank]\h]+
[[:blank:]\h]*
)
|
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[[:blank:]\h]*
(?<quote>[""'])
(.*?)
\g{quote}
[[:blank:]\h]*
)
)
)";
string input = @"<abbr title=""`first backtick!"">SB</abbr>
<abbr title=""`second backtick!"">SB</abbr>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}