$re = '/(?:(?<=\n\n)|\A\n*|\n{2,})
[ ]{0,3}
(?<tag_all>
(?:
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
>
(?<html_content>.*?)
(?<tag_close>
<
[[:blank:]\h\v]*
\/
\g{tag_name}
[[:blank:]\h\v]*
>
)
)
|
(?:
<!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->
)
|
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
(?<html_after>
\z
|
[ ]*\n{1,2}
(?!
[[:blank:]\h\v]*
(?:
(?:
<
[[:blank:]\h\v]*
[a-zA-Z0-9][\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
>
)
|
(?:
<
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
[\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
)
)
)
(?(DEFINE)
(?<tag_attr>
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[^\"\'[:blank]\h]+
[[:blank:]\h]*
)
|
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[[:blank:]\h]*
(?<quote>["\'])
(.*?)
\g{quote}
[[:blank:]\h]*
)
)
)/xsmJ';
$str = '<abbr title="`first backtick!">SB</abbr>
<abbr title="`second backtick!">SB</abbr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);