import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\n\\n)|\\A\\n*|\\n{2,})\n"
+ "[ ]{0,3}\n"
+ "(?<tag_all>\n"
+ " (?:\n"
+ " (?:\n"
+ " <\n"
+ " [[:blank:]\\h\\v]*\n"
+ " (?<tag_name>[a-zA-Z0-9][\\w\\-]+)\n"
+ " (?<tag_attributes>(?&tag_attr))*\n"
+ " [[:blank:]\\h\\v]*\n"
+ " >\n"
+ " (?<html_content>.*?)\n"
+ " (?<tag_close>\n"
+ " <\n"
+ " [[:blank:]\\h\\v]*\n"
+ " \\/\n"
+ " \\g\\{tag_name\\}\n"
+ " [[:blank:]\\h\\v]*\n"
+ " >\n"
+ " )\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " <!--[[:blank:]\\h\\v]*(?<html_comment>.*?)[[:blank:]\\h\\v]*-->\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " <\n"
+ " [[:blank:]\\h\\v]*\n"
+ " (?<tag_name>[a-zA-Z0-9][\\w\\-]+)\n"
+ " (?<tag_attributes>(?&tag_attr))*\n"
+ " [[:blank:]\\h\\v]*\n"
+ " \\/?\n"
+ " [[:blank:]\\h\\v]*\n"
+ " >\n"
+ " )\n"
+ " )\n"
+ " (?<html_after>\n"
+ " \\z\n"
+ " |\n"
+ " [ ]*\\n{1,2}\n"
+ " (?!\n"
+ " [[:blank:]\\h\\v]*\n"
+ " (?:\n"
+ " (?:\n"
+ " <\n"
+ " [[:blank:]\\h\\v]*\n"
+ " [a-zA-Z0-9][\\w\\-]+\n"
+ " (?:(?&tag_attr))*\n"
+ " [[:blank:]\\h\\v]*\n"
+ " >\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " <\n"
+ " [[:blank:]\\h\\v]*\n"
+ " \\/?\n"
+ " [[:blank:]\\h\\v]*\n"
+ " [\\w\\-]+\n"
+ " (?:(?&tag_attr))*\n"
+ " [[:blank:]\\h\\v]*\n"
+ " \\/?\n"
+ " [[:blank:]\\h\\v]*\n"
+ " >\n"
+ " )\n"
+ " )\n"
+ " )\n"
+ " )\n"
+ ")\n"
+ "(?(DEFINE)\n"
+ " (?<tag_attr>\n"
+ " (?:\n"
+ " [[:blank:]\\h]*\n"
+ " [\\w\\-]+\n"
+ " [[:blank:]\\h]*\n"
+ " =\n"
+ " [^\\\"\\'[:blank]\\h]+\n"
+ " [[:blank:]\\h]*\n"
+ " )\n"
+ " |\n"
+ " (?:\n"
+ " [[:blank:]\\h]*\n"
+ " [\\w\\-]+\n"
+ " [[:blank:]\\h]*\n"
+ " =\n"
+ " [[:blank:]\\h]*\n"
+ " (?<quote>[\"'])\n"
+ " (.*?)\n"
+ " \\g\\{quote\\}\n"
+ " [[:blank:]\\h]*\n"
+ " )\n"
+ " )\n"
+ ")";
final String string = "<abbr title=\"`first backtick!\">SB</abbr> \n"
+ "<abbr title=\"`second backtick!\">SB</abbr>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}