import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = #"""
(?:(?<=\n\n)|\A\n*|\n{2,})
[ ]{0,3}
(?<tag_all>
(?:
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
>
(?<html_content>.*?)
(?<tag_close>
<
[[:blank:]\h\v]*
\/
\g{tag_name}
[[:blank:]\h\v]*
>
)
)
|
(?:
<!--[[:blank:]\h\v]*(?<html_comment>.*?)[[:blank:]\h\v]*-->
)
|
(?:
<
[[:blank:]\h\v]*
(?<tag_name>[a-zA-Z0-9][\w\-]+)
(?<tag_attributes>(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
(?<html_after>
\z
|
[ ]*\n{1,2}
(?!
[[:blank:]\h\v]*
(?:
(?:
<
[[:blank:]\h\v]*
[a-zA-Z0-9][\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
>
)
|
(?:
<
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
[\w\-]+
(?:(?&tag_attr))*
[[:blank:]\h\v]*
\/?
[[:blank:]\h\v]*
>
)
)
)
)
)
(?(DEFINE)
(?<tag_attr>
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[^\"\'[:blank]\h]+
[[:blank:]\h]*
)
|
(?:
[[:blank:]\h]*
[\w\-]+
[[:blank:]\h]*
=
[[:blank:]\h]*
(?<quote>["'])
(.*?)
\g{quote}
[[:blank:]\h]*
)
)
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
<abbr title="`first backtick!">SB</abbr>
<abbr title="`second backtick!">SB</abbr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)