using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(#\d+ )?(\w+) ([^|]+)";
string input = @"#12 1320 Water Street|Kelowna, British Columbia V1Y9P4
1320 Water Street|Kelowna, British Columbia V1Y9P4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}