package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#\d+ )?(\w+) ([^|]+)`)
var str = `#12 1320 Water Street|Kelowna, British Columbia V1Y9P4
1320 Water Street|Kelowna, British Columbia V1Y9P4
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}