#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\r\n.]*(?<!\S)(TableA)(?!\S)[^\r\n.]*$"
Local $sString = " Test TableA" & @CRLF & _
" TableA AWord" & @CRLF & _
" TableA AWord" & @CRLF & _
" This.TableA" & @CRLF & _
" This. TableA Aword"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")