using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\r\n.]*(?<!\S)(TableA)(?!\S)[^\r\n.]*$";
string input = @" Test TableA
TableA AWord
TableA AWord
This.TableA
This. TableA Aword";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}