import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\r\\n.]*(?<!\\S)(TableA)(?!\\S)[^\\r\\n.]*$";
final String string = " Test TableA\n"
+ " TableA AWord\n"
+ " TableA AWord\n"
+ " This.TableA\n"
+ " This. TableA Aword";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}