re = /^[^\r\n.]*(?<!\S)(TableA)(?!\S)[^\r\n.]*$/m
str = ' Test TableA
TableA AWord
TableA AWord
This.TableA
This. TableA Aword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end