use strict;
my $str = '-z001 230001 20 X
-z011 26321 10 *
-z002 230000 10 X
-z003 134242 12 *
-z004 199999 10 X
-z005 299999 20 X';
my $regex = qr/.* ([0-9]|[1-9][0-9]{1,4}|1[0-9]{5}|2[0-2][0-9]{4}|230000) [12]0 X.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}