import re
regex = re.compile(r".* ([0-9]|[1-9][0-9]{1,4}|1[0-9]{5}|2[0-2][0-9]{4}|230000) [12]0 X.*", flags=re.MULTILINE)
test_str = ("-z001 230001 20 X\n"
"-z011 26321 10 *\n"
"-z002 230000 10 X\n"
"-z003 134242 12 *\n"
"-z004 199999 10 X\n"
"-z005 299999 20 X")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")